[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Bus error on svn export (SVN 1.2.0 / Mac OS X 10.4.1 / DarwinPorts 1.001)

From: Ryan Schmidt <subversion-2005_at_ryandesign.com>
Date: 2005-07-10 20:18:34 CEST

On 01.07.2005, at 21:56, Ryan Schmidt wrote:

> Hi. I'm getting a reproducable bus error in svn export, and I think
> the trigger is when the working copy is in a mixed-revision state.
> My Subversion is 1.2.0 installed using DarwinPorts 1.001 on Mac OS
> X 10.4.1. Transcript:
>
>
> $ cd /tmp
> $ svnadmin create svntest
> $ mkdir foo
> $ touch foo/bar
> $ svn import foo file:///tmp/svntest/foo -m ''
> Adding foo/bar
>
> Committed revision 1.
> $ rm -R foo
> $ svn co file:///tmp/svntest/foo foo
> A foo/bar
> Checked out revision 1.
> $ svnversion foo
> 1
> $ svn export foo fooexport
> Export complete.
> $ rm -R fooexport
> $ svn mv foo/bar foo/baz
> A foo/baz
> D foo/bar
> $ svnversion foo
> 1M
> $ svn export foo fooexport
> Export complete.
> $ rm -R fooexport
> $ svn ci foo -m ''
> Deleting foo/bar
> Adding foo/baz
>
> Committed revision 2.
> $ svnversion foo
> 1:2
> $ svn export foo fooexport
> Bus error
> $ rm -R fooexport
> $ svn up foo
> At revision 2.
> $ svnversion foo
> 2
> $ svn export foo fooexport
> Export complete.
> $ svn --version
> svn, version 1.2.0 (r14790)
> compiled Jul 1 2005, 01:38:00
>
> Copyright (C) 2000-2005 CollabNet.
> Subversion is open source software, see http://subversion.tigris.org/
> This product includes software developed by CollabNet (http://
> www.Collab.Net/).
>
> The following repository access (RA) modules are available:
>
> * ra_dav : Module for accessing a repository via WebDAV (DeltaV)
> protocol.
> - handles 'http' scheme
> - handles 'https' scheme
> * ra_svn : Module for accessing a repository using the svn network
> protocol.
> - handles 'svn' scheme
> * ra_local : Module for accessing a repository on local disk.
> - handles 'file' scheme

FYI and for the archives, I don't see this anymore after updating to
DarwinPorts 1.010 and Subversion 1.2.1 today. Don't know if it was a
DarwinPorts problem, or a Subversion 1.2.0 problem, or if it just got
built improperly the first time. Either way, it works now.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sun Jul 10 20:20:33 2005

This is an archived mail posted to the Subversion Users mailing list.