[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Symlinks with umlauts

From: Hunkel, Manfred <M.Hunkel_at_t-systems.com>
Date: 2005-07-01 14:52:58 CEST

| -----Ursprüngliche Nachricht-----
| Von: Saulius Grazulis [mailto:grazulis@akl.lt]
| Gesendet: Freitag, 1. Juli 2005 10:20
| An: users@subversion.tigris.org
| Betreff: Re: Symlinks with umlauts
|
| On Friday 01 July 2005 09:57, Hunkel, Manfred wrote:
|
| > | $ svn ci -m"test"
| > | Hinzufügen     äöüß
| > | Übertrage Daten .svn: Übertragen fehlgeschlagen (Details folgen):
| > | svn: Can't read contents of link: Datei oder Verzeichnis nicht gefunden
| > |
| > | ("Datei oder Verzeichnis nicht gefunden" = "File or Directory not found")
| >
| > I can corroborate this (SVN 1.1.4, built on NetBSD 1.6.2)
| >
| > Note that my locale has LC_CTYPE=de_DE.ISO8859-1 and actions
| > dealing with regular files with umlauts in their names work fine...
|
| Uffff... your example works on my machine, both with LC_CTYPE=de_DE.ISO8859-1,
| LC_ALL=de_DE.ISO8859-1, bdb backend...
|
| What about libc version? Maybe that one is a culprit? Which libc does NetBSD
| 1.6.2 use?
|

An interesting question. I've got:

-r--r--r-- 1 root wheel 703659 Feb 10 2004 /usr/lib/libc.so.12.83.2

but I haven't a clue how this correlates with libc versions on, e.g., Linux.

I will have to check this issue on a NetBSD 2.0 installed on another box.
For me, the problem as such is not relevant. We only use Tortoise clients
and for us there's nor reason to use symlinks anyway. I just wanted to
contribute my €0.02

;-) -Manfred

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jul 1 14:56:51 2005

This is an archived mail posted to the Subversion Users mailing list.