[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Kerberos Authentification + Authorization with groups

From: John Szakmeister <john_at_szakmeister.net>
Date: 2005-06-30 11:53:23 CEST

On Thursday 30 June 2005 03:58, Didier Trosset wrote:
> John Szakmeister wrote:
> > On Wednesday 29 June 2005 12:26, Didier Trosset wrote:
> >>Hi,
> >>
> >> ----- 8< -----
> >>
> > I've found that with kerberos authentication the @ACQIRIS.CH is
>
> considered
>
> > part of the username. Also, in the second version of your authz
> > file, your missing the :/ (I can't remember if that really matters or
> > not off hand, but I always put it there).
>
> You're right. (The :/ were here.) It works now using:
> [svn-www:/]
> dtrosset@ACQIRIS.CH
>
> But As soon as I try to create groups:
> [groups]
> www-editors = dtrosset@ACQIRIS.CH other@ACQIRIS.CH

These values should be comma separated.

> [svn-www:/]
> @www-editors
>
> I got this 401 error again !
>
> Do you know anything about this ?
>
>
> And additionnal question, I guessed from all I have seen around the Web
> that Kerberos is *the* solution for authenticating against a M$ Windows
> Server 2003 (with Active Directory). Hope I'm guessing correctly?

I can't speak directly about this, but we use an UNIX version of Active
Directory (called XAD, available from www.padl.com). And the
mod_auth_krb5 authenticates against it just fine.

-John

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jun 30 12:26:30 2005

This is an archived mail posted to the Subversion Users mailing list.