[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Segmentation fault using svn v1.2.0 under Cygwin

From: Max Bowsher <maxb_at_ukf.net>
Date: 2005-06-24 16:24:05 CEST

Matthew S. Moore wrote:
> kfogel@collab.net wrote:
>> "Matthew S. Moore" <mmoore@asf.alaska.edu> writes:
>>
>>> Does anyone have any idea why svn.exe/svnserve.exe might be getting
>>> Segmentation faults?
>>
>>
>> No, but if you can give us an actual reproduction recipe, we might be
>> able to figure it out... See http://svn.collab.net/repos/svn/trunk/BUGS.

> After attempting to check out my full repository to reproduce the
> segmentation faults again, I found that all of the crashes occurred when
> the
> pathname being added was more than 10 directories deep. So I tested this
> with a fresh repository.
>
[snip recipe]
>
> I also tested this on a Linux system (2.6.10-1.766_FC3smp) installed
> with
> the same version of Subversion, but did not have this problem.
>
> I know that svn.exe did not crash when checking out the same full
> repository prior to upgrading to svn v1.2.0 from v1.1.4.
>
> Thus, this appears to be some kind of limitation associated with
> Cygwin/Windows and svn v1.2.0. Anyone have any ideas what might cause
> this?

Most curious.

With your script, I can reproduce the segfault with 1.2.0, but with svn
trunk (i.e. 1.3.0-dev) all is well.

Hmm....

Max.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jun 24 16:26:03 2005

This is an archived mail posted to the Subversion Users mailing list.