[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Bug or my understanding - mod_svn_authz

From: Greg Loscombe <greg_at_eutechnyx.com>
Date: 2005-06-22 15:56:36 CEST

Just been trying to setup some authz control on a repos and have hit
what looks like a bug. If I give full rw permission to all users, then
try and take that permission away from a specific user, that user is
still given access?

Example:-

[Physics:/]
* = rw
Andrew =

When Andrew goes to do a co, after sending his password, he can get rw
access....

If I did it the other way round, and denied access and then gave it to
people, it seems to work:-
[Physics:/]
* =
@everyonebutandrew = rw

There is an example which seems to suggest this should work:-
http://svnbook.red-bean.com/en/1.1/svn-book.html#svn-ch-6-sect-4.4.2

[paint:/projects/paint]
@paint-developers = rw
jane = r

Using gentoo, with Subversion 1.2.0 unmasked for x86. Any pointers?

Thanks in advance
Greg Loscombe

_____________________________________________________________________
This e-mail is confidential and may be privileged. It may be read, copied and used only by the intended recipient. No communication sent by e-mail to or from Eutechnyx is intended to give rise to contractual or other legal liability, apart from liability which cannot be excluded under English law.

This message has been checked for all known viruses by Star Internet delivered through the MessageLabs Virus Control Centre.

www.eutechnyx.com Eutechnyx Limited. Registered in England No: 2172322

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Jun 22 16:00:22 2005

This is an archived mail posted to the Subversion Users mailing list.