[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: "svn: No such revision '1'" error during checkout

From: Monks, Peter <peter.monks_at_vignette.com>
Date: 2005-06-20 21:46:03 CEST

G'day Karl,

> This is very bizarre.

Yeah, and I don't recall seeing it with pre-1.2 clients connecting to
the
same 1.0.5 server, although it's been a while since I created a new
repos on it, so there's a chance the last time I did this I was using a
1.0.x client.

> Do you have administrative access to the repository?

Yep.

> Can you successfully run 'svnadmin dump > /dev/null' on it?

Yep. The output was:

    * Dumped revision 0.

> What directory are you in on the client side when you run this?

C:\Dev\test

> Is there a working copy named 'repos' there?

Nope - I created the "test" directory afresh straight after creating
the repository. Most of the subdirectories under C:\Dev are also
working copies (from different repositories / URLs), but they're each
contained in a dedicated subdirectory. Would that be causing issues,
perhaps? There is no "C:\Dev\.svn" directory so it isn't (or
shouldn't be!) a working copy.

Attached are transcripts of what I ran on the server, and then on the
client.

Cheers,
Peter

PS. I stand corrected - we're running on SVN 1.0.4, not 1.0.5. I
    guess it's about time I got cracking on the long-delayed upgrade.
    ;-)

----------------------------------------------------------------------
Peter Monks http://www.sydneyclimbing.com/
pmonks_at_sydneyclimbing.com http://www.geocities.com/yosemite/4455/
----------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org

Received on Mon Jun 20 21:47:39 2005

This is an archived mail posted to the Subversion Users mailing list.