[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

svnserve only listens on TCP6 on Freebsd 5.4

From: gui <gui_at_function.com>
Date: 2005-06-14 23:59:08 CEST

*Hi Kay

I have the same problem as you, and am wondering if you have found a
solution to the problem.
I installed subversion 1.2.0 on Freebsd 5.4 and svnserve only listens on
tcp6.
How to change it to tcp4?

Thank you very much in anticipation

Gui
California

Subject:* Re: 1.2.0 svnserve only listens on ipv6 on openbsd
*From:* /abendroth_at_wsc-gmbh.de/
<mailto:abendroth_at_wsc-gmbh.de?Subject=Re:%201.2.0%20svnserve%20only%20listens%20on%20ipv6%20on%20openbsd>
*Date:* 2005-05-31 15:11:26 CEST

    * *Next message:* Rowell, Geoff: "RE: Re: svn cleanup questions"
      <http://svn.haxx.se/users/archive-2005-05/1842.shtml>
    * *Previous message:* Daniel Berlin: "Re: fsfs migration failure.
      File too large??"
      <http://svn.haxx.se/users/archive-2005-05/1840.shtml>
    * *Maybe in reply to:* Jim Morris: "1.2.0 svnserve only listens on
      ipv6 on openbsd"
      <http://svn.haxx.se/users/archive-2005-05/1379.shtml>
    * *Messages sorted by:* [ date ]
      <http://svn.haxx.se/users/archive-2005-05/date.shtml#1841> [
      thread ]
      <http://svn.haxx.se/users/archive-2005-05/index.shtml#1841> [
      subject ]
      <http://svn.haxx.se/users/archive-2005-05/subject.shtml#1841> [
      author ]
      <http://svn.haxx.se/users/archive-2005-05/author.shtml#1841> [
      attachment ]
      <http://svn.haxx.se/users/archive-2005-05/attachment.shtml>

------------------------------------------------------------------------

Hello,

I also have this problem, but on FreeBSD 5.4-STABLE.
svnserve is listening on tcp6 only:

# netstat -an | grep 3690
tcp6 0 0 *.3690 *.*
LISTEN

/usr/ports/devel/subversion was compiled with the following flags:
WITHOUT_NEON=yes
WITH_SVNSERVE_WRAPPER=yes

Kind regards,
Kay Abendroth

*Subject:* 1.2.0 svnserve only listens on ipv6 on openbsd
*From:* Jim Morris (/morris_at_wolfman.com/
<mailto:morris_at_wolfman.com?Subject=Re:%201.2.0%20svnserve%20only%20listens%20on%20ipv6%20on%20openbsd>)
*Date:* 2005-05-24 00:12:29 CEST

    * *Next message:* Craig McElroy: "Mac OS X Subversion Package for
      1.2.0" <http://svn.haxx.se/users/archive-2005-05/1380.shtml>
    * *Previous message:* Ryan Schmidt: "Re: Different urls for the same
      repository" <http://svn.haxx.se/users/archive-2005-05/1378.shtml>
    * *Next in thread:* abendroth_at_wsc-gmbh.de: "Re: 1.2.0 svnserve
      only listens on ipv6 on openbsd"
      <http://svn.haxx.se/users/archive-2005-05/1841.shtml>
    * *Maybe reply:* abendroth_at_wsc-gmbh.de: "Re: 1.2.0 svnserve only
      listens on ipv6 on openbsd"
      <http://svn.haxx.se/users/archive-2005-05/1841.shtml>
    * *Messages sorted by:* [ date ]
      <http://svn.haxx.se/users/archive-2005-05/date.shtml#1379> [
      thread ]
      <http://svn.haxx.se/users/archive-2005-05/index.shtml#1379> [
      subject ]
      <http://svn.haxx.se/users/archive-2005-05/subject.shtml#1379> [
      author ]
      <http://svn.haxx.se/users/archive-2005-05/author.shtml#1379> [
      attachment ]
      <http://svn.haxx.se/users/archive-2005-05/attachment.shtml>

------------------------------------------------------------------------

Hi,

I have just built 1.2.0 on OpenBSD, and when I run svnserve it only
listens on the ipv6 network, and there is no listen port on ipv4.

Is there a way to tell it to ignore ipv6? or at least have it listen on
both?

--------------------------------------------------------------------
Received on Wed Jun 15 00:05:58 2005

This is an archived mail posted to the Subversion Users mailing list.