[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Installing PECL svn

From: Maarten van der Veen <mjvdveen_at_ai.rug.nl>
Date: 2005-06-06 10:33:06 CEST

Yes, I get the following compile error:

checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend
checking for PHP extension
directory... /usr/local/lib/php/extensions/no-debug-non-zts-20041030
checking for re2c... exit 0;
checking for gawk... gawk
checking for svn support... yes, shared
checking for svn includes... configure: error: failed to find apr.h

This file can be found on quite a few places on my system, but the
configure does not have a parameter for it.

Cheers,

Maarten

On Mon, 2005-06-06 at 13:42 +0800, Alan Knowles wrote:
> can you try this config.m4
> http://www.akbkhome.com/svn/pecl/svn/config.m4
>
> - then run
> phpize;./configure;make clean;make install;
>
> And let me know if there are any compile errors.
> Regards
> Alan
>
> On Mon, 2005-06-06 at 13:28 +0800, Alan Knowles wrote:
> > Can you send me a full log of the errors.
> > Regards
> > Alan
> >
> > On Mon, 2005-06-06 at 16:04 +1200, Maarten van der Veen wrote:
> > > Well, this helped for this ./configure, which ended without errors.
> > >
> > > The make however seems to have trouble compiling svn.lo
> > >
> > > /usr/src/peclsvn/svn-0.1/svn.c:1780: `result_rev' undeclared (first use
> > > in this function)
> > > /usr/src/peclsvn/svn-0.1/svn.c:1781: request for member `ctx' in
> > > something not a structure or union
> > > /usr/src/peclsvn/svn-0.1/svn.c: In function `php_svn_get_version':
> > > /usr/src/peclsvn/svn-0.1/svn.c:1797: syntax error before '*' token
> > > /usr/src/peclsvn/svn-0.1/svn.c:1798: `vers' undeclared (first use in
> > > this function)
> > > make: *** [svn.lo] Error 1
> > >
> > > And lots more where that come from.
> > >
> > > Cheers,
> > >
> > > Maarten
> > >
> > > On Mon, 2005-06-06 at 07:51 +0800, Alan Knowles wrote:
> > > > I'm not 100% sure if it will work with 1.2
> > > >
> > > > if svn_client.h is here:
> > > > /usr/include/subversion-1/svn_client.h
> > > > use:
> > > >
> > > > ./configure --with-svn=/usr
> > > >
> > > > if svn_client.h is here:
> > > > /opt/include/subversion-1/svn_client.h
> > > > use:
> > > >
> > > > ./configure --with-svn=/opt
> > > >
> > > > Should work.. There is a way we can add this to the pear install script,
> > > > (I also need to get it to work with older versions of pear.. - which I
> > > > was dicussing with the author or the pear installer.)
> > > >
> > > > Let me know if you have any luck.
> > > >
> > > > Regards
> > > > Alan
> > > >
> > > > On Mon, 2005-06-06 at 09:33 +1200, Maarten van der Veen wrote:
> > > > > So Allen, is there a way to compile and make it work with subversion 1.2
> > > > > now? It looks like it's mainly a problem with the paths, but the 1.7
> > > > > version of config.m4 does also use the svn-config as far as I know.
> > > > >
> > > > > Cheers,
> > > > >
> > > > > Maarten
> > > > >
> > > > > On Sun, 2005-06-05 at 23:13 +0800, Alan Knowles wrote:
> > > > > > Wez added the svn-config, we presumed it was a standard. However debian
> > > > > > doesnt package it, so we fell back to standard inc. paths if it is
> > > > > > missing...
> > > > > >
> > > > > > It looks like using it at all may be problematic.
> > > > > >
> > > > > > BTW. we targeted 1.1, and have not tested it with 1.2 - We will think
> > > > > > about targeting 1.2 in the next releases.
> > > > > >
> > > > > > Regards
> > > > > > Alan
> > > > > >
> > > > > > On Sun, 2005-06-05 at 16:30 +0200, Ryan Schmidt wrote:
> > > > > > > On 05.06.2005, at 16:24, Max Bowsher wrote:
> > > > > > >
> > > > > > > > Ryan Schmidt wrote:
> > > > > > > >>> Then it needs svn-config, which is part of the svn developer package,
> > > > > > > >>> which I hadn't installed.
> > > > > > > >
> > > > > > > > Actually, svn-config is _not_ a supported part of the Subversion
> > > > > > > > distribution at all. It's been known to be old, out-of-date, and at
> > > > > > > > least partially broken since before svn 1.0, IIRC, and the Subversion
> > > > > > > > project's official tarballs do _not_ install it.
> > > > > > > >
> > > > > > > > Unfortunately, some packagers seem to have taken it upon themselves to
> > > > > > > > install it anyway, and some dependent packages have started to use it
> > > > > > > > in spite of all this.
> > > > > > > >
> > > > > > > > Which pretty much tells you that any time you see a configure script
> > > > > > > > using "svn-config", you are in for a less than pleasant experience.
> > > > > > >
> > > > > > > Oh, I see. Thanks for the info.
> > > > > > >
> > > > > > > Alan, you getting all of this? :-)
> > > > > > >
> > > > > > > \r
> > > > > > >
> > > > > > >
> > > > >
> > >
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > > For additional commands, e-mail: users-help@subversion.tigris.org
> > >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: users-help@subversion.tigris.org
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Jun 6 10:48:27 2005

This is an archived mail posted to the Subversion Users mailing list.