[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problem compiling 1.2 under Mandriva Linux

From: Jeff Lanzarotta <delux256-subversion_at_yahoo.com>
Date: 2005-06-02 19:49:12 CEST

Ok, a little more information:

I found that the problem is occuring during the 'local-install' portion
of the makefile.

If I change:

install: external-install local-install revision-install

to:

install: local-install

The makefile bombs out immediately...

--- Jeff Lanzarotta <delux256-subversion@yahoo.com> wrote:

> Yeap, compiling and installing as root...
>
> When I change the DOITPROG to echo, nothing happens...
>
> I'm still digging...
>
> --- john geldman <jgeldman@gmail.com> wrote:
>
> > One amateurs view:
> >
> > I presume you are doing the install as root...
> >
> > Also, remember that the lovely behavior of linux scripts is to
> blame
> > the "not found" on the script that had the problem, not on the
> > command
> > in the script that failed. I'd normally look deeper into
> > ac-helpers/install-sh to figure out what is going on. (by the way
> > /usr/local/lib exists?)
> >
> > There is a hint in that script that reads
> > # set DOITPROG to echo to test this script
> > Don't use :- since 4.3BSD and earlier shells don't
> > like it.
> > doit="${DOITPROG-}"
> >
> > Good luck, JG
> >
> > On 6/1/05, Jeff Lanzarotta <delux256-subversion@yahoo.com> wrote:
> > > Opps, sorry... the problem is not during an actual compile, it's
> > during
> > > the 'make install' that I get this problem. The 'make' by itself
> > works
> > > just fine...
> > >
> > > --- Jeff Lanzarotta <delux256-subversion@yahoo.com> wrote:
> > >
> > > > Hello,
> > > >
> > > > I'm attempting to compile version 1.2 under Mandriva Linux. I'm
> > > > getting
> > > > the following error:
> > > >
> > > > --------8<--------
> > > > .
> > > > .
> > > > .
> > > > make[1]: Leaving directory `/mnt/hdc1/subversion-1.2.0/neon'
> > > > ------ completed install in neon
> > > > /mnt/hdc1/subversion-1.2.0/ac-helpers/install-sh -c -d
> > /usr/local/lib
> > > > make: /mnt/hdc1/subversion-1.2.0/ac-helpers/install-sh: Command
> > not
> > > > found
> > > > make: *** [install-fsmod-lib] Error 127
> > > >
> > > > --------8<--------
> > > >
> > > > I'm taking a look and the file exists and the permissions like
> > fine.
> > > > Any ideas?
> > > >
> > > > Regards,
> > > >
> > > > -Jeff
> > > >
> > > >
> >
> ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > > > For additional commands, e-mail:
> users-help@subversion.tigris.org
> > > >
> > > >
> > >
> > >
> > >
> >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > > For additional commands, e-mail: users-help@subversion.tigris.org
> > >
> > >
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: users-help@subversion.tigris.org
> >
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jun 2 19:52:36 2005

This is an archived mail posted to the Subversion Users mailing list.