[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Subclipse 0.9.31 OS X

From: Scott Palmer <scott.palmer_at_2connected.org>
Date: 2005-05-30 17:18:19 CEST

On May 30, 2005, at 9:43 AM, Mark Phippard wrote:

> Subversion installs its libraries in the correct locations but Java
> doesn't
> look in that location to load the libraries.

Subversion must have a very interesting interpretation of "correct".
If the location was correct it would work, or is my concept of
"correct" warped by my insistence on using logic :) ?

> Since the Metissian packages just work out of the box, I suspect
> that there
> installer must create symlinks in some OS X folder that causes the
> libraries to seen by Java. Perhaps an email on the Subversion
> users@ list
> could get more details about what they do. And yes, perhaps the
> Subversion
> make script could be enhanced to create these symlinks too.

Yes, I think that is the proper solution. "make install-javahl" by
necessity should leaving things in a state where the JNI library will
load successfully by the Java runtime.

I'm copying the Subversion list. To recap...

I built Subversion 1.2.x on OS X. Did "make install" and make
"install-javahl". Both appeared to complete without any errors.
However, the Subclipse plugin is unable to load the javahl library,
presumably because various bits of native code are not in a place
accessible by the Java runtime. I interpret this as "make install-
javahl" not doing it's job adequately.

Scott

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon May 30 17:19:51 2005

This is an archived mail posted to the Subversion Users mailing list.