[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: subversion 1.2.0 fails a number of self tests

From: Cem Karan <ckaran_at_arl.army.mil>
Date: 2005-05-26 14:59:06 CEST

> Folks,
>
> I downloaded and do the initial building of subversion 1.2.0 and
> have run it a problem. The builds run okay but the "make check"
> fail a number of tests. The 1.1.4 version passes all of the
> tests. I am using the software under the following envirment
>
> Slackware 10.1 (Linux svn 2.4.29 #6 Thu Jan 20 16:30:37 PST
> 2005 i686 unknown unknown GNU/Linux)
> httpd-2.0.53
> apr-0.9.6
> apr-util-0.9.6
> apr-iconv-0.9.5
> openssl-0.9.7g
> Berkeley DB 4.2.52 gcc-3.3.4
>
> Subversion 1.1.4 has been built and installed with the same
> software. The files svn_build.log is a log of the configuration,
> make and make check in a 'script" log file. svn_configure is the
> script used to run configure.
>
> Any help is appreciated.

I don't know if this will help you or not; it works on OS X systems.

./autogen.sh (The SVN developers say this isn't needed; I tend to do
it because it seems to make things work better for me. YMMV)

./configure --disable-shared --enable-maintainer (Turning off shared
solves a problem with the neon library; maintainer mode so that if
something breaks you can give better info to the maintainers)

make

make check
Received on Thu May 26 15:04:56 2005

This is an archived mail posted to the Subversion Users mailing list.