[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: 1.1.4 BDB repository troubles/warning/question

From: Shatzer, Larry <Larry.Shatzer_at_MIROtechnologies.com>
Date: 2005-05-24 15:42:16 CEST

I ran into this issue, and it turns out the BDB version shipped with 1.2 is
newer then the version I was using, so I had to use the binaries from the
old svn to do a dump, and then with the new 1.2 do a load.

-- Larry

-----Original Message-----
From: Miha Vitorovic [mailto:mvitorovic@nil.si]
Sent: Tuesday, May 24, 2005 6:24 AM
To: users@subversion.tigris.org
Subject: 1.1.4 BDB repository troubles/warning/question

Hi all,

I just installed version 1.2 for Windows today. I'm using it with Apache.
I had 3 repositories in BDB, two production ones and a test. I reloaded
the production ones from the dump files, for the xdelta, and they're reall
fast now, but I left the test repository as it was - it should be backward
comptabile.

Well, the test repository doesn't work any more. This is what it says in
Firefox.

<D:error>
<C:error/>
<m:human-readable errcode="160029">
Could not open the requested SVN filesystem
</m:human-readable>
</D:error>

Apache log file:

[Tue May 24 15:11:58 2005] [error] (20014)Error string not specified yet:
Berkeley DB error for filesystem C:/test-rep/db while opening
environment:\nDB_VERSION_MISMATCH: Database environment version mismatch
[Tue May 24 15:11:58 2005] [error] Could not fetch resource information.
[500, #0]
[Tue May 24 15:11:58 2005] [error] Could not open the requested SVN
filesystem [500, #160029]
[Tue May 24 15:11:58 2005] [error] Could not open the requested SVN
filesystem [500, #160029]

Cheers,

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue May 24 15:48:14 2005

This is an archived mail posted to the Subversion Users mailing list.