[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: Recovering corrupted repository

From: Hunkel, Manfred <M.Hunkel_at_t-systems.com>
Date: 2005-03-30 15:48:29 CEST

Ah! WinXP, The Strange Beast! There must be a whole trove of messages about setting APR_ICONV_PATH etc. in this list's archive. I'm not an expert in this, so can't really help out. One question: Did you consider using TortoiseSVN as a client? I did have problems with umlauts once using the *NIX clients server-side, but Tortoise has always worked like charm on the same repository...

;-) -Manfred

| -----Ursprüngliche Nachricht-----
| Von: Plagge, Michael (CARMEQ) [mailto:michael.plagge@carmeq.com]
| Gesendet: Mittwoch, 30. März 2005 15:25
| An: 'Peter Kahn'; users@subversion.tigris.org
| Betreff: RE: Recovering corrupted repository
|
| Hi,
|
| perhaps I forgot to mention :-), that I have to work under WinXP and I am
| not sure, if setting LC_CTYPE and LANG also works here. In fact I tried, and
| it makes no difference. I also tried to set ARP_ICONV_PATH to
| C:\Programme\Subversion\iconv but this had also no effect.
|
| best wishes
| michael
|
| -----Original Message-----
| From: Peter Kahn [mailto:pkahn@connected.com]
| Sent: Wednesday, March 30, 2005 2:44 PM
| To: Plagge, Michael (CARMEQ); users@subversion.tigris.org
| Subject: RE: Recovering corrupted repository
|
|
| Possibly this is not a corruption, but actually a localization or
| internationalization issue. I would look to see that the environment
| variables LC_CTYPE and LANG are set properly. In my company, we set them to
| en_US.UTF-8
| perhaps, you'd want to set them to a different character set?
|
|
|
|
| From: Plagge, Michael (CARMEQ) [mailto:michael.plagge@carmeq.com]
| Sent: Wed 3/30/2005 6:07 AM
| To: 'users@subversion.tigris.org'
| Subject: Recovering corrupted repository
|
|
| Hi all,
|
| i have a problem with a corrupted SVN-repository. Assume the following
| layout for our repository
|
| /svnrep
| /dir1
| /dir2
| /dir3_with_problems_according_to_umlauts
| /dir4
| /dir5
|
| When i issue a cvs checkout command like:
|
| cvs checkout file///c:/svnrep
|
| i get the following error message while svn tries to checkout /dir3*
|
| svn: Can't check path 'svnrep\G?\252tefunktionen f?\252r': Invalid argument
| (as you can see there are umlauts in the path name)
|
| ---------------------------------------------------------------------
| To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
| For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Mar 30 15:51:09 2005

This is an archived mail posted to the Subversion Users mailing list.