[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problem compiling swig-py

From: Jeff Lanzarotta <delux256-subversion_at_yahoo.com>
Date: 2005-03-18 20:16:40 CET

Humm...

I setup my Makefile with the output of get-pg-info.py. Now I get a
multitude of errors...

------8<------
[root@rogdrake subversion-1.1.3]# make swig-py
/bin/sh /mnt/hdc1/subversion-1.1.3/libtool --silent --mode=compile gcc
-pthread -fno-strict-aliasing -DNDEBUG -O2 -fomit-frame-pointer -pipe
-march=i586 -mtune=pentiumpro -g -fPIC -DLINUX=2 -D_REENTRANT
-D_XOPEN_SOURCE=500 -D_BSD_SOURCE -D_SVID_SOURCE -D_GNU_SOURCE
-I/mnt/hdc1/subversion-1.1.3/subversion/bindings/swig
-I/mnt/hdc1/subversion-1.1.3/subversion/include -I -DSVN_SWIG_VERSION=
-I/mnt/hdc1/subversion-1.1.3/apr/include
-I/mnt/hdc1/subversion-1.1.3/apr-util/include
-I/mnt/hdc1/subversion-1.1.3/apr-util/xml/expat/lib
-I/mnt/hdc1/subversion-1.1.3/subversion/bindings/swig/python/libsvn_swig_py
-prefer-pic -c -o subversion/bindings/swig/python/svn_client.lo
subversion/bindings/swig/python/svn_client.c
subversion/bindings/swig/python/svn_client.c:14:20: Python.h: No such
file or directory
subversion/bindings/swig/python/svn_client.c:342: error: syntax error
before '*' token
subversion/bindings/swig/python/svn_client.c:343: error: syntax error
before '*' token
subversion/bindings/swig/python/svn_client.c:343: warning: data
definition has no type or storage class
subversion/bindings/swig/python/svn_client.c:344: error: syntax error
before '*' token
subversion/bindings/swig/python/svn_client.c:345: error: syntax error
before '*' token
------8<------

I believe I have all the python stuff setup:

[root@rogdrake build]# rpm -qa | grep -i python
python-imaging-1.1.4-6mdk
libpython2.3-2.3.4-6.1.101mdk
libxml2-python-2.6.13-1.1.101mdk
python-2.3.4-6.1.101mdk
python-base-2.3.4-6.1.101mdk
libpython2.3-devel-2.3.4-6.1.101mdk

Any ideas? Sheeze, I didn't have any problems installing under Mandrake
10.0...

--- Joey Mukherjee <joey@swri.edu> wrote:
>
> On Mar 18, 2005, at 12:09 PM, Jeff Lanzarotta wrote:
>
> > Hello Joey,
> >
> > You were right in that the .py files (there were others) were
> > incorrect. I fixed the files and did a ./configure and make remade
> svn
> > again. I then did a 'make swig-py' and received the same error as
> > before. :(
> >
> > Any ideas?
>
> You will have to fill in SWIG_PY_COMPILE manually. Run
> build/get-py-info.py --compile and put the result of that in
> SWIG_PY_COMPILE in the Makefile. Run build/get-py-info.py --link and
>
> put that in SWIG_PY_LINK in the Makefile.
>
> I really don't know why this isn't working automatically.
>
> Joey
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Mar 18 20:19:07 2005

This is an archived mail posted to the Subversion Users mailing list.