[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Problem compiling swig-py

From: Jeff Lanzarotta <delux256-subversion_at_yahoo.com>
Date: 2005-03-18 19:09:30 CET

Hello Joey,

You were right in that the .py files (there were others) were
incorrect. I fixed the files and did a ./configure and make remade svn
again. I then did a 'make swig-py' and received the same error as
before. :(

Any ideas?

--- Joey Mukherjee <joey@swri.edu> wrote:
> I had this problem and if you look at the Makefile for
> SWIG_PY_COMPILE,
> you'll see that this is not filled in. You can fix this manually by
>
> putting in the right values.
>
> However, in check my facts for this message, I think I found the
> problem. There is a script in build called get-py-info.py which is
> not
> executable and is missing the line #!/bin/python as the first line.
>
> Add that as the first line and do a chmod 755 get-py-info.py and I
> bet
> the configure script will actually work. I haven't tested it since I
>
> manually filled it in.
>
> Anyway, that's the problem. Maybe this is fixed already?
>
> On Mar 18, 2005, at 8:26 AM, Jeff Lanzarotta wrote:
>
> > Hello,
> >
> > I've just installed Mandrake 10.1 and now I'm trying to reinstall
> SVN.
> > My repositories are all FSFS so I have configured SVN to not use
> BDB.
> > From what I can tell I have compiled and installed SVN correctly,
> but
> > when I try to make swig-py, I get the following:
> >
> > [root@rogdrake subversion-1.1.3]# make swig-py
> > /bin/sh /mnt/hdc1/subversion-1.1.3/libtool --silent --mode=compile
> > -DLINUX=2 -D_REENTRANT -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
> -D_SVID_SOURCE
> > -D_GNU_SOURCE
> -I/mnt/hdc1/subversion-1.1.3/subversion/bindings/swig
> > -I/mnt/hdc1/subversion-1.1.3/subversion/include -I
> -DSVN_SWIG_VERSION=
> > -I/mnt/hdc1/subversion-1.1.3/apr/include
> > -I/mnt/hdc1/subversion-1.1.3/apr-util/include
> > -I/mnt/hdc1/subversion-1.1.3/apr-util/xml/expat/lib
> > -I/mnt/hdc1/subversion-1.1.3/subversion/bindings/swig/python/
> > libsvn_swig_py
> > -prefer-pic -c -o subversion/bindings/swig/python/svn_client.lo
> > subversion/bindings/swig/python/svn_client.c
> > libtool: unrecognized option `-DLINUX=2'
> > Try `libtool --help' for more information.
> > make: *** [subversion/bindings/swig/python/svn_client.lo] Error 1
> >
> > Any idea why?
> >
> > Regards,
> >
> > -Jeff
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: users-help@subversion.tigris.org
> >
> >
> Joey
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Mar 18 19:12:21 2005

This is an archived mail posted to the Subversion Users mailing list.