[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Propfind failed on repository root

From: Michael Ditum <mrskensington_at_gmail.com>
Date: 2005-02-14 15:22:20 CET

managed to fix it myself just had to change...

<Location /svn/>

to

<Location /svn>

in my apache config... just documenting it in case anyone else has this problem.

On Wed, 9 Feb 2005 08:51:54 +0000, Michael Ditum
<mrskensington@gmail.com> wrote:
> A while ago I had subversion set up and working fine at
> https://myserver.com/svn/repos/ i decided to change this to
> https://myserver.com/svn/ just to make it look nicer... everything
> seemed to be running fine... I could update and commit quite happily
> and also checkout subdirectories e.g.
> https://myserver.com/svn/project1/
>
> However I no longer seem to be able to checkout the root subversion
> directory, meaning I cant add any more projects at the moment...
>
> DrEvil backup # svn co https://myserver.com/svn/
> svn: PROPFIND request failed on '/svn'
> svn: PROPFIND of '/svn': 405 Method Not Allowed (https://myserver.com)
>
> if i view the url in my browser I can see the repository fine however
> I get this error message if i try to check out the root or try to view
> anything in tortoisesvn's repository browser...
>
> my user info is stored in /var/svn/conf/svnusers and my repository is
> in /var/svn/repos...
>
> the /var/svn/ directory is recursively owned by apache:apache with
> permissions 770
>
> this is an ls -l of /var/svn/
> DrEvil svn # ls -l
> total 0
> drwxrwx--- 2 apache apache 72 Jul 3 2004 conf
> drwxrwx--- 7 apache apache 224 Jul 3 2004 repos
>
> and an ls -l of /var/svn/repos/
> DrEvil repos # ls -l
> total 11
> -rwxrwx--- 1 apache apache 376 Jul 3 2004 README.txt
> drwxrwx--- 2 apache apache 80 Jul 3 2004 conf
> drwxrwx--- 2 apache apache 112 Jul 3 2004 dav
> drwxrwx--- 2 apache apache 3072 Feb 8 22:19 db
> -rwxrwx--- 1 apache apache 2 Jul 3 2004 format
> drwxrwx--- 2 apache apache 232 Jul 3 2004 hooks
> drwxrwx--- 2 apache apache 104 Jul 3 2004 locks
>
> this is in my apache config file
> <IfDefine SVN>
> <IfModule !mod_dav_svn.c>
> LoadModule dav_svn_module extramodules/mod_dav_svn.so
> </IfModule>
> <Location /svn/>
> DAV svn
> SVNPath /var/svn/repos/
> AuthType Basic
> AuthName "Subversion repository"
> AuthUserFile /var/svn/conf/svnusers
> Require valid-user
> </Location>
> </IfDefine>
>
> nothing is printed to apache's ssl_error_log but the following is
> printed to apache's ssl_access_log...
> 63.111.22.74 - - [08/Feb/2005:11:14:07 +0000] "PROPFIND /svn HTTP/1.1" 405 381
>
> Does anyone know how to fix my problem???
>
> Thanks in advance!
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Feb 14 15:25:35 2005

This is an archived mail posted to the Subversion Users mailing list.