[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

ERROR "svn: Can't read directory entry in <repos>"

From: Michael Hordijk <hoffbrinkle_at_hotmail.com>
Date: 2005-01-19 15:09:28 CET

> > Michael Hordijk wrote:
> > > I'm getting the following error when attempting an hotcopy on one of
my
> > > repositories:
> > >
> > > $ svnadmin hotcopy atg /tmp/atg
> > > svn: Can't read directory entry in 'atg/db': Partial results are valid
> but
> > > processing is incomplete
> >
> > Check the permissions of all files in there (and the db directory, of
> > course).
> >
> > Also, try to run the command as root.
>
> No go, I've made sure that all files are owned by apache, and I've
tried
> running it as root, same error.
> Other than this command, the entire repository is working just fine.
> Still checking things in/out and everything.
> I'm running 1.1.1 (still waiting for something newer to become marked
> x86 stable in Gentoo).

    So does anyone know enough about BDB and/or SVN to be to give a hint as
to what this error message means? I was hoping that I'd be able to use
hotcopy to make snapshot of the repository that I can then back up. Would
any one on the devel list have any ideas?

- hoffer

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Jan 19 15:12:29 2005

This is an archived mail posted to the Subversion Users mailing list.