[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: 403 Forbidden errors hitting Win2K Apache Repo

From: Ben Collins-Sussman <sussman_at_collab.net>
Date: 2005-01-17 15:31:01 CET

On Jan 16, 2005, at 11:52 PM, Steve Johnson wrote:

> Hey Ben,
>
> Thanks much for the reply! Your email did just the trick to point me
> in
> the right direction. It hadn't hit me yet that the access method was
> the issue.
>
> Since my problem existed even when I tried to do a checkout via HTTP on
> the svn server itself, I knew I had to look at the way Apache was
> configured. Sure enough, by explicitly forcing the access permissions
> wide open on REPORT, I was able to get a checkout to succeed.
>
> I don't understand why my default setup didn't work. The Subversion
> docs for setting up Apache don't mention this. I combed over the
> Apache
> docs and my httpd.conf file, but I see nothing to explain why GET would
> be accepted but REPORT rejected if neither of them is ever mentioned
> explicitly. Can you offer any enlightenment here?
>

I don't understand. There was no web proxy at all?

You say you had to "explicitly force the access permissions wide open
on REPORT", but I have no idea what you're talking about. Show us
specific examples of how things were, and exactly what you had to do.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Jan 17 15:34:35 2005

This is an archived mail posted to the Subversion Users mailing list.