[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: local directory "obstructed"

From: John Bokma <mail_at_johnbokma.com>
Date: 2005-01-12 18:58:30 CET

Hi Per,

> I have a local sandbox where one subtree of the directory acts weird.
> (WEB-INF/classes/com). I run both svn 1.1.1 and TortoiseSVN 1.1.2
> under WinXP-SP2.

[ snip ]

> All subdirectories contain a hidden .svn directory, except
> WEB-INF/classes/com (and its subdirectories).

I had a similar problem a few days ago. What I did (and maybe it solves
your problem too). Back up the top level directory and all it's
contents, check out the repository in either a new directory, or delete
the toplevel directory and re-create it and use that one to check out in.

Next add the files back you have updated *without* the .svn directories
and its contents.

Add the new files the usual way, and commit should work.

-- 
John                               MexIT: http://johnbokma.com/mexit/
                            personal page:       http://johnbokma.com/
    Experienced Perl programmer available:     http://castleamber.com/
             Happy Customers: http://castleamber.com/testimonials.html
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Jan 12 19:39:31 2005

This is an archived mail posted to the Subversion Users mailing list.