[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Compiling Subversion 1.1.2 for Win32

From: Barry Scott <barry_at_barrys-emacs.org>
Date: 2005-01-01 00:04:55 CET

Python dev folks claim you cannot use Python 2.4 with extensions built
with
MSVC 6.0. You need to use C++ .NET 2003.

Barry

On Dec 31, 2004, at 00:36, James Park ((pencil_ethics)) wrote:

> Since nobody was providing binaries for Win32, I've been trying to =
> compile Subversion 1.1.2 on a Windows box.
> After a week of fiddling, I've succeeded in building it, only to see
> it =
> fail the first UTF-8 test of the test suite with the following:
>
> the non-ASCII characters -> ...
> CMD: svn.exe "add" "working_copies\utf8_tests-1\bOcA" "--config-dir" =
> "C:\svn\src
> -1.1.2\Release\subversion\tests\clients\cmdline\local_tmp\conf=
> ig" <TIME =3D 0.125000>
> Failed to schedule i18n filename for addition
> EXPECTED STDERR:
> ACTUAL STDERR:
> svn: Safe data:
> "working_copies\utf8_tests-1\b"
> ... was followed by non-ASCII byte 212.
>
> Non-ASCII character detected (see above), and unable to convert
> to/from =
> UTF-8
> EXCEPTION: SVNLineUnequal
> FAIL: utf8_tests.py 1: conversion of paths and logs to/from utf8
>
> I compiled Subversion with the following:
>
> 1) Visual C++ 6.0 SP6
> 2) ActiveState Perl 5.8.6.811
> 3) Berkeley DB 4.3.27 (compiled by me with 1)
> 4) Python 2.4
> 5) GNU libiconv 1.9.1 (compiled by me with 1)
> 6) GNU gettext 0.13 (compiled by me with 1)
> 7) Neon (version included in source zip, using 9 and 11)
> 8) Apache 2.0.52 and APR 0.9.5 (compiled by me with 1 and using 3)
> 9) zlib 1.2.2 (compiled by me with 1)
> 10) NASM (obtained from where INSTALL tells you to get it)
> 11) OpenSSL 0.9.7e (compiled by me with 1 and 2 using 10)
> 12) All on an XP Pro SP2 (Korean) box and XP MCE 2005 (English) box.
>
> I hoped that the language difference would resolve the issue, but =
> obviously it didn't, since the same error came up in both boxes, =
> although on the XP Pro (Korean) box svnlook failed a test as follows:
>
> CMD: svnlook.exe "diff" "repositories\svnlook_tests-3" <TIME =3D =
> 0.719000>
>
> EXPECTED :
>
> Property changes on: iota
> ___________________________________________________________________
> Name: bogus_prop
> + bogus_val
>
> ACTUAL :
>
> Property changes on: iota
> ___________________________________________________________________
> Name: bogus_prop
>
> + bogus_val
> EXCEPTION: SVNLineUnequal
> FAIL: svnlook_tests.py 3: test the printing of property diffs
>
> Did I miss any details, and what settings do I need to set wherever to
> =
> resolve the UTF-8 problem?
>
> Any form of help/advice would be greatly appreciated. If not, I'll
> just =
> wait for the official binaries to come out.
>
> Thanks in advance,
>
> James Park
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sat Jan 1 00:07:07 2005

This is an archived mail posted to the Subversion Users mailing list.