[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Password Mismatch authz_svn

From: Paolo Casarini <paolo_at_casarini.org>
Date: 2004-11-15 11:18:38 CET

Hi,

 I use subversion 1.0.9 on apache2 2.0.52 that runs on a Debian Sarge Linux
Box. Without the authz_svn module with the following configuration the Basic
Authentication works correctly:

<Location /svn>
 DAV svn
 SVNParentPath /var/repos

 AuthType Basic
 AuthName "Subversion Repository"
 AuthUserFile /etc/apache2/dav_svn.passwd
 Require valid-user
</Location>

When I modify dav_svn.conf to use th authz module, the authintication with
the same users that works correctly before, now don't work. To use the authz
modulo I use the following conf file.

<Location /svn>
 DAV svn
 SVNParentPath /var/repos

 AuthType Basic
 AuthName "Subversion Repository"
 AuthUserFile /etc/apache2/dav_svn.passwd
 AuthzSVNAccessFile /etc/apache2/dav_svn.authz
 Satisfy Any
 Require valid-user
</Location>

The dav_svn_passwd is the same and with authz module loaded apache2 write
Password Mismatch in the error.log.

The dav_svn.authz file is like the following:
[group]
prbm-devel = paolo
dp-devel = paolo,davide

[dp:/]
* =
@dp-devel = rw

[prbm:/]
* = r
@prbm-devel = rw

So, where is my fault?

Thanx,
 Paolo.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Nov 15 11:20:06 2004

This is an archived mail posted to the Subversion Users mailing list.