[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Issue with svn log, maybe more...

From: Greg Ward <gward_at_python.net>
Date: 2004-09-30 03:36:21 CEST

On 28 September 2004, barry.kaplan@gmail.com said:
> Thanks that did the trick a there was a ^H in the log.

I stumbled across this about a year-and-a-half ago. Asked on the list
at the time, and I *think* there was some consensus that this is a
cvs2svn bug. (At the very least, it should crash and burn on
encountering control characters in log messages.) Can't remember if a
filed a bug report at the time, but a quick search of the cvs2svn bug
database (err, sorry, "issue tracker" ;-) turns up nothing.

You might want to file a bug report now and save future people the
headache that you and I both suffered. It doesn't take a "pile of Perl
goo" (nice turn of phrase) to put control chars into a CVS/RCS log
message -- clumsy fingers when entering a log message in emacs will do
it too.

I imagine this one will be pretty easy to reproduce and easy to fix (as
long as everyone agrees that "cvs2svn dies horribly on control char in
log message" is the correct behaviour.)

        Greg

-- 
Greg Ward <gward_at_python.net>                         http://www.gerg.ca/
We have always been at war with Oceania.
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Sep 30 03:37:43 2004

This is an archived mail posted to the Subversion Users mailing list.