[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: getting "svn: PROPFIND of xxxxx: could not connect to server" error...

From: S.Ramaswamy <ramaswamy_at_collab.net>
Date: 2004-09-07 12:38:42 CEST

bruce wrote:

>hi...
>
>unsuccessfully trying to set up an apache/subversion repository access
>environment.
>
>i have rh8.0
> apache2.0.50
> subversion-1.1.0-rc2
> berkeley 4.0.52
>
>

Berkeley db 4.0.52 ? That's a bit old - might want to update to 4.2.52.

Not sure though, if that's the reason for the error.

Ramaswamy

>i can access the repository via the 'svn' client when i setup the default
>svnserve deamon.
>
>when i try to access the repository via the apache, i get the error:
> svn: PROPFIND request failed on '/svntest2'
> svn: PROPFIND of '/svntest2': could not connect to server
>(http://192.168.1.52)
>
>
>the access log is:
>192.168.1.52 - - [06/Sep/2004:23:08:30 -0700] "PROPFIND /svntest2 HTTP/1.1"
>500 234 "-" "SVN/1.1.0 (Release Candidate 2) neon/0.24.7"
>1
>
>
>the error log is:
>[Mon Sep 06 23:08:09 2004] [notice] core dump file size limit raised to
>4294967295 bytes
>[Mon Sep 06 23:08:10 2004] [warn] module dav_module is already loaded,
>skipping
>[Mon Sep 06 23:08:10 2004] [warn] module php5_module is already loaded,
>skipping
>[Mon Sep 06 23:08:10 2004] [notice] mod_python: Creating 32 session mutexes
>based on 150 max processes and 0 max threads.
>[Mon Sep 06 23:08:10 2004] [notice] Digest: generating secret for digest
>authentication ...
>[Mon Sep 06 23:08:10 2004] [notice] Digest: done
>[Mon Sep 06 23:08:11 2004] [notice] Apache/2.0.50 (Fedora) PHP/5.0.0
>mod_python/3.1.3 Python/2.3.3 DAV/2 SVN/1.1.0-rc2 configured -- resuming
>normal operations
>[Mon Sep 06 23:08:30 2004] [error] [client 192.168.1.52] (20014)Error string
>not specified yet: Can't open file '/svnroot/format': No such file or
>directory
>[Mon Sep 06 23:08:30 2004] [error] [client 192.168.1.52] Could not fetch
>resource information. [500, #0]
>[Mon Sep 06 23:08:30 2004] [error] [client 192.168.1.52] Could not open the
>requested SVN filesystem [500, #2]
>[Mon Sep 06 23:08:30 2004] [error] [client 192.168.1.52] Could not open the
>requested SVN filesystem [500, #2]
>
>
>the portion of the config file that deals with dav/svn is:
>LoadModule dav_module modules/mod_dav.so
>LoadModule dav_svn_module modules/mod_dav_svn.so
><Location /svntest2>
> DAV svn
> SVNPath /svnroot
>#
># # Limit write permission to list of valid users.
># <LimitExcept GET PROPFIND OPTIONS REPORT>
># # Require SSL connection for password protection.
># # SSLRequireSSL
>#
># AuthType Basic
># AuthName "Authorization Realm"
># AuthUserFile /absolute/path/to/passwdfile
># Require valid-user
># </LimitExcept>
></Location>
>
>i rebuilt the svn apps from source and connected them to the current version
>of the berkeley db on my box... i didn't want to do a complete rebuild of
>apache as well....
>
>everything appears to be as it should be... however, given that it doesn't
>work, there's an error somewhere!!! searching through google indicates that
>others have had a smiliar problem, but nothing shed any light onto what the
>issue really is.
>
>any pointers/comments/thoughts are appreciated...
>
>thanks
>
>-bruce
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
>For additional commands, e-mail: users-help@subversion.tigris.org
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Sep 7 12:39:45 2004

This is an archived mail posted to the Subversion Users mailing list.