[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Broken repository... Help!

From: Greg Martyn <gmartyn_at_verizon.net>
Date: 2004-08-23 19:36:28 CEST

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On Monday 23 August 2004 12:58 pm, Max Bowsher wrote:
> Robert William Jones wrote:
> > Hi there

> If you are lucky, then making a *copy* of your repository and removing
> (from a COPY), __db.*, and then trying "svnadmin recover repospath", and
> then if that doesn't work "db_recover -vec" (executed from the db
> subdirectory of the copy of the repository), will fix things. If not, try
> the same again, this time try removing both __db.* and log.* . If you now
> have a functioning repository _don't_ put it back into service - "svnadmin
> dump" it, and load the dump into a new repository.
>
> If not, tar or zip your repository, put it on a web/ftp site, and email me
> the url (privately if you wish), and I'll see what I can do.

This should be in an FAQ somewhere..

- --Greg
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFBKiseTbK6opmKUmoRAmQbAJ9tnvwhaLEvPpLFJWqEh7ZOAng1SwCgk4mX
XmB/nUJdp2+mNMT59fgapsE=
=bB/U
-----END PGP SIGNATURE-----

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Aug 23 19:36:51 2004

This is an archived mail posted to the Subversion Users mailing list.