[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Subversion upgrade issues

From: Laurent Duperval <lduperval_at_yahoo.com>
Date: 2004-08-14 15:49:20 CEST

On Thu, 12 Aug 2004 07:08:43 -0700, David Ripton wrote:
>> I believe
>> at the time of my original installation I was using a db 4.0.x flavour,
>> but I'm not sure. I'mcurrently using 4.1.25.
>
> It would be good to know for sure. Check /var/log/emerge.log Or browse
> the Gentoo CVS tree to see when a 4.1 version was unmasked to get an
> estimate, if you upgrade everything often.
>

I checked. The last time I used SVN successfully was in April. At the time
I was using db-4.1.25_p1-r3. Sometime in May I re-emerged it as part of
a large deep update (I think I tried porthole and it messed up my tree
or something). On Aug 4 I updated to r4. I think I did that because it
wasn't working anymore. So basically, it looks like I've been using the
same version of db since February.

I can try to go back to r3 to see if the problem disappears.

> 1. Backup your repository files!

I'll try this also to see what happens.

> 2. Completely uninstall bsddb, then install bsddb 4.0.14-r3 (If you have
> more than one version of bsddb on the system, Subversion will find a way
> to use the wrong one. :->

bsddb is a Python package. You probably mean "db". If not, let me know.

L

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sat Aug 14 15:50:09 2004

This is an archived mail posted to the Subversion Users mailing list.