[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Peculiar Subversion problem

From: Dave Flynn <dflynn_at_carleton.edu>
Date: 2004-08-13 16:54:53 CEST

Greetings all,

We've been working with Subversion for quite a while, but a couple of
days ago we ran into some odd problems. Some of our repositories are
working fine; the users who are supposed to have access to them do have
access, and nobody else does. However, some of the repositories cannot
be accessed at all; a web browser or svn client simply hangs if one
attempts to access them. I've checked and rechecked the permissions, and
I don't see a problem there.

I then tried svnadmin recover on the failing repositories, and got
behavior I'd never seen before; the 'svnadmin recover' command itself
hung. There's no indication of what's going on in any of the error logs
I've looked at, and I'm kind of at a loss.

For reference, all of the repositories, the good and the bad, are found
in the same /svn parent directory. They have identical permissions.

I'm at a loss to explain this behavior...could anyone offer some advice?
If there's more information you need, please let me know.

Thanks much,
~Dave

David Flynn
Technical Associate in Unix Systems Administration
Carleton College
(507) 646-7836

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Aug 13 17:02:51 2004

This is an archived mail posted to the Subversion Users mailing list.