[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Subversion upgrade issues

From: Laurent Duperval <lduperval_at_yahoo.com>
Date: 2004-08-12 14:24:33 CEST

Hi,

I use Gentoo Linux. Subversion 1.0.x where x < 4 used to work for me. I
hadn't touched my installation for a long time, but I've periodically
upgraded.

Today, I'm trying to use it again but it doesn't work. I get an error
saying:

svn: Unable to open an ra_local session to URL
svn: Unable to open repository 'file:///mnt/share/svnrepos/mysoft/trunk'
svn: Berkeley DB error while opening environment for filesystem
/mnt/share/svnrepos/db:
Resource temporarily unavailable

I can telnet correctly to localhost:3690. I can do a "svn diff" and see
correct results. But I can't do an update or a commit.

Does anyone know what could be the problem? According to some messages
on the list, this could be due to the version of db I'm using. I believe
at the time of my original installation I was using a db 4.0.x flavour,
but I'm not sure. I'mcurrently using 4.1.25. DB 4.2 isn't available yet
for Gentoo.

Any ideas what my best course of action is at this point?

Thanks,

L

P.S. I am not subscribed to the list. A CC would be appreciated.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Aug 12 14:33:50 2004

This is an archived mail posted to the Subversion Users mailing list.