[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: win32/cygwin swig-perl-lib build not possible

From: Max Bowsher <maxb_at_ukf.net>
Date: 2004-07-30 17:30:52 CEST

Ronny T. Lampert wrote:
> Hi,
>
> I just wanted to ask if anybody has managed to build the swig-perl
bindings
> for svn under cygwin?
> I could not find any useful docs despite heavy searching and fiddling
around.
>
> During the normal build, libtool is complaining that it can't link against
a
> static lib and bails out with unresolved symbols; it also seems that no
> dynamic libs are built.
>
> The configure-call was simply: ./configure --with-zlib --with-perl
> (Adding --enable-shared does not help.)
>
> The "make swig-pl-lib" runs, but doing the perl Makefile.PL in
> subversion/bindings/swig/perl/ fails with:
> "Channot chdir to ../../libsvn_client/.libs/: No such file or directory at
> Makefile.PL line 45."

I'm working on this, and have actually run a "svk sync" under Cygwin.

However, the difference between kludging a working build on my system and
getting it into a package is non-trivial.

There will be a subversion-perl and svk package for Cygwin. I'm cautious
about about giving a time estimate, but my tentative guess would be about 1
to 2 weeks after 1.1.0.

Max.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jul 30 17:33:12 2004

This is an archived mail posted to the Subversion Users mailing list.