[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Seg faults

From: Alex Sandro Queiroz e Silva <ventonegro_at_ventonegro.org>
Date: 2004-07-23 19:53:05 CEST

Hallo,

    I've been using subversion for about a month now, and it's an
awesome piece of software. I'm having some problems, but my guess is
that this is about the machine I'm using.
    Using subversion at home (Debian unstable) and with my repository
server (Debian pinned) is flawless. But at my machine at work (Debian
unstable) I get seg faults in almost every svn operation. My binary
doesn't have debug information for I've installed it using apt-get. But
strace gives me:

--- BEGIN STRACE OUTPUT ---

$ strace svn st

stat64("src/drawables/watervolume.hpp", {st_mode=S_IFREG|0644,
st_size=3552, ...}) = 0
lstat64("src/drawables/.svn/text-base/watervolume.hpp.svn-base",
{st_mode=S_IFREG|0444, st_size=3246, ...}) = 0
lstat64("src/drawables/.svn/props/watervolume.hpp.svn-work",
{st_mode=S_IFREG|0444, st_size=4, ...}) = 0
lstat64("src/drawables/.svn/props/watervolume.hpp.svn-work",
{st_mode=S_IFREG|0444, st_size=4, ...}) = 0
open("src/drawables/.svn/props/watervolume.hpp.svn-work", O_RDONLY) = 3
read(3, "END\n", 4096) = 4
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

--- END STRACE OUTPUT ---

The seg fault seems to occur the first time svn tries to read a file.
Has anybody else experienced this? Is this really an issue with this
machine? Every other software works very well. Any advice will be
appreciated.

-alex

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jul 23 19:54:09 2004

This is an archived mail posted to the Subversion Users mailing list.