[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: database corruption

From: Max Bowsher <maxb_at_ukf.net>
Date: 2004-07-16 18:10:21 CEST

Pejvan BEIGUI wrote:
> OK, I'm having a headache now, since Fink automatically updated 1.0.4 to
> 1.0.5 and hence removed the old version. I have to find out a way to
> install the old version.

OK, then never mind with the otool stuff.

> I'm CCing Christian Schaffner who's the package maintainer of svn for
> Fink and who has been really helpful eachtime someone had a problem with
> svn. Maybe he can help?

Sounds like a good idea, get an OS X expert's opinion.

>> Or, maybe you could put a tarball of your repository files on a web/ftp
site
>> somewhere, and I'll investigate them.
>>
> This could be a solution, but I have my commercial projects in the
> repository,
> and I'm not sure my clients would appreciate this :(

Fair enough.

Try this:

Make a *copy* of your repository. Using this copy:

Delete the __db.00* files from the db subdirectory of the repository.

Run "svnadmin verify" on the repository.

If it works, great, if not, post the exact error message.

Max.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Jul 16 18:11:02 2004

This is an archived mail posted to the Subversion Users mailing list.