[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: installing subversion under Linux 9.0

From: David Summers <david_at_summersoft.fay.ar.us>
Date: 2004-07-15 04:22:28 CEST

On Thu, 15 Jul 2004, emani wrote:

> I'm trying to install the subversion on my server which runs under Linux9.0
> I'm having a problem like this:
> #rpm -i subversion-1.0.5-1.rh90.i386.rpm
> error: Failed dependencies:
> apr >= 0.9.5 is needed by subversion-1.0.5-1
> apr-util >= 0.9.5 is needed by subversion-1.0.5-1
> OK it say it needs Apache
> I do:
> # rpm -i apr-0.9.5-0.2.i386.rpm
> error: Failed dependencies:
> subversion < 0.20.1-2 conflicts with apr-0.9.5-0.2
> It says it need subversion.
> I understand that subversion is a part of Apache but how to install both rpm's?

First, please send email to users@subversion.tigris.org instead of
directly to me so everyone can benefit.

OK, It looks like you might have a version of subversion < 0.20.1-2
installed on your system.

You could either erase the existing apr, apr-util, and subversion and
install the new ones or just do

rpm -Uvh subversion* apr*

for your new install, the "U" means upgrade which will uninstall your old
packages and install the new ones.

If you are currently using an older version of Subversion on your
repositories, make sure you have backups of the repositories and your old
RPMs before upgrading.

-- 
David Wayne Summers          "Linux: Because reboots are for hardware upgrades!"
david_at_summersoft.fay.ar.us   PGP Key: http://summersoft.fay.ar.us/~david/pgp.txt
PGP Key fingerprint =  C0 E0 4F 50 DD A9 B6 2B  60 A1 31 7E D2 28 6D A8 
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Jul 15 04:22:50 2004

This is an archived mail posted to the Subversion Users mailing list.