[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: FC2 RPM svnserve problem

From: Axel Thimm <Axel.Thimm_at_ATrpms.net>
Date: 2004-07-08 13:05:34 CEST

On Thu, Jul 08, 2004 at 11:27:12AM +0100, Eric Carlson wrote:
> Clean FC2 rpm, svn from http://atrpms.net/name/subversion/. The rpm I
> used was subversion-1.0.5-0_3.rhfc2.at.i386.rpm which went in without
> a hitch & it seems to start up ok with svnserve not reporting any
> errors. As soon as I run svn though I hit this
> http://subversion.tigris.org/project_faq.html#redhat-db
> with a slightly different message:
>
> [root_at_gonzo svntest]# svn checkout svn://localhost/j2me
> svn: Berkeley DB error while opening environment for filesystem
> /data/Vol1/Subversion/j2me/db:
> Invalid argument
> [root@gonzo svntest]#

Is that a K6, Pentium I or otherwise pre-i686? Then it's a db/nptl
issue like Joeri's quoted bugzilla entry.

On Thu, Jul 08, 2004 at 12:30:49PM +0200, Joeri De Backer wrote:
> Its probably this bug:
> https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=91933
>
> I installed the rpms from
> http://tomi.nomi.cz/download/db4-no-nptl/
> (forced) and it worked for me!

On Thu, Jul 08, 2004 at 11:33:48AM +0100, Paulo Sousa Dias wrote:
> FC2 has a uptodate version of subversion (they call it 1.0.4-2 with
> is 1.0.5). I'm using it and have no problems.
> Why are you not using the "official" version?

He probably found that these also fail in the same way, I believe.

-- 
Axel.Thimm at ATrpms.net

  • application/pgp-signature attachment: stored
Received on Thu Jul 8 13:06:05 2004

This is an archived mail posted to the Subversion Users mailing list.