[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: svn: Berkeley DB error while creating environment for filesystem svn/db: Invalid argument

From: David Summers <david_at_summersoft.fay.ar.us>
Date: 2004-03-24 04:30:35 CET

On Mon, 22 Mar 2004, Wang Li wrote:

> I'm a fedora core 1 user who interest the subversion greatly. After download
> the binary rpm provided rpm from the office download site, I issue the
> following commands:
>
> To install them (subversion-1.0.1, apr-0.9.5-0.3, apr-0.9.5-0.4,
> db42-4.2.52-0.1,):
>
> rpm -ivh --force db42-*
> rpm -Uvh apr-*
> rpm -ivh subversion-*
>
> Because db4-4.1.25 is required by many other rpms provided by fedora and I
> won't to recompile all of these packages to upgrade to db42, so I keep
> db4-4.1.25....
>

I'm curious as why you are having to "force" the db42 package. I changed
it from db4-4.2.52 to db42-4.2.52 specifically so people wouldn't
accidentally upgrade their db4-4.1.25 packages. You shouldn't have to
force it. Did you try it without forcing it? If so, what was the result?

I'm using it with no (known) problems for the last week or so. Still more
work to do for the next release, though.

-- 
David Wayne Summers          "Linux: Because reboots are for hardware upgrades!"
david_at_summersoft.fay.ar.us   PGP Key: http://summersoft.fay.ar.us/~david/pgp.txt
PGP Key fingerprint =  C0 E0 4F 50 DD A9 B6 2B  60 A1 31 7E D2 28 6D A8 
---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Wed Mar 24 04:51:19 2004

This is an archived mail posted to the Subversion Users mailing list.