[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: upgrading FC1 system from the summersoft repo?

From: Craig Robson <craig_at_zhatt.com>
Date: 2004-03-22 17:33:31 CET

Many people have seen the problems with db4.1. I ran many tests and with
db4.1 and the problems were quite repeatable. Lockups, wedged repository,
etc.

One test that we used was to create a new repository and grab the gcc source
code and try to check it in and out a few times. It always failed on db4.1
for me.

----- Original Message -----
From: "Adam Gibson" <agibson@ptm.com>
To: <users@subversion.tigris.org>
Sent: Monday, March 22, 2004 7:34 AM
Subject: Re: upgrading FC1 system from the summersoft repo?

> I appreciate all the work that the packager of the summersoft site has
> gone through to supply us all with easily installable packages of
> subversion(hats off to you).
>
> I am rather surprised though that he didn't just compile it against the
> already installed db4-4.1.25-14. I have not had any problems with the
> db4 that fedora core 1 comes with going back to version .32 of
> subversion(currently at .37). That would have solved needing a new db4
> and needing to supply another version of apache, which can break
> dependencies on other third party RPMS that require the fedora core 1
> httpd and db4(not so much db4 now since he has a special db42 rpm).
>
> I realize that db 4.1 is not recommended going by previous posts from
> other distros, but RedHat tends to backport fixes to packages, so maybe
> that is why 4.1 works fine for me. Is there something I am missing that
> would require not using the httpd and db4 4.1.25 that redhat supplies
> with fedora core 1?
>
> I plan to just take the subversion src rpm on summersoft.fay.ar.us and
> recompile it on the current fedora core 1 so that I can use the existing
> httpd and db4. Has anyone already done this and had problems? It would
> have been nice to just yum update off of summersoft.fay.ar.us binaries
> though without changing the current db4 and httpd.
>
> On Sun, 2004-03-21 at 06:31, Robert P. J. Day wrote:
> > has anyone else updated their FC1 system to subversion 1.0.1 from
> > the summersoft repo? i did that, and it's causing all sorts of problems
> > based on what looks like the libdb-related RPMs at that repo.
> >
> > from what i can tell, those "db42*" RPMs don't officially provide
> > libdb-4.1.so capability, which breaks a number of other things. i'm
> > going to investigate further, but i'd be interested in hearing from
> > anyone who's updated subversion on their FC1 system, and how well
> > it worked.
> >
> > rday
>
> --
> Adam Gibson <agibson@ptm.com>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Mar 22 17:34:08 2004

This is an archived mail posted to the Subversion Users mailing list.