[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: SSL errors

From: Cristiano Paris <paris_at_disp.uniroma2.it>
Date: 2004-03-20 00:29:00 CET

On Fri, Mar 19, 2004 at 07:44:55PM +0000, Joe Orton wrote:
> On Fri, Mar 19, 2004 at 08:10:48PM +0100, Cristiano Paris wrote:
> > On Fri, Mar 19, 2004 at 05:53:30PM +0000, Joe Orton wrote:
> > > On Fri, Mar 19, 2004 at 06:34:35PM +0100, Cristiano Paris wrote:
> > > > One friend of mine is trying to use a subversion over https
under Linux
> > > > (Gentoo). He is using:
> > > >
> > > > subversion 1.0
> > > > neon 0.24.4
> > > > ssl 0.9.7d
> > > >
> > > > If he tries to check out the files from the repository he gets the
> > > > following error:
> > > >
> > > > "SSL error: decryption failed or bad record mac"
> > >
> > > Does connecting using:
> > >
> > > $ openssl s_client -connect server.host.name:443
> > >
> > > from the same machine work?
> >
> > Yes it work.
>
> OK, what's the entire error message from the svn client, also check
> whether there are any errors in the server error_log.

No errors at all. The server flush all the data to the client. No error
in the log.

Cristiano

----
Web: http://www.disp.uniroma2.it/users/paris
Public PGP/GnuPG key
pub  1024D/32CA6D54 2004-01-23 Cristiano Paris (RHPK) <c.paris@email.it>
     Key fingerprint = 3BFD 9884 230A 1F17 391C  1434 80CB 2C7A 32CA 6D54
----

  • application/pgp-signature attachment: stored
Received on Sat Mar 20 00:28:35 2004

This is an archived mail posted to the Subversion Users mailing list.