[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Solaris 8 Configure Problems

From: Justin Johnson <justinjohnson_at_fastmail.fm>
Date: 2004-03-02 18:19:16 CET

On the commandline below I *did* set CC=gcc. Actually, after looking
further I found that installing the package SUNWarc fixed the problem.

Now I have a new problem to track down.

$ env CC=gcc ../dist/configure
...
...
...
checking how to run the C preprocessor... /lib/cpp
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.

Then I find the following in config.log:

configure:4042: gcc -c -O -D_REENTRANT conftest.c >&5
In file included from configure:3997:
/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.3.2/include/stdio.h:36:27:
iso/std
io_iso.h: No such file or directory
In file included from configure:3997:
/usr/local/lib/gcc-lib/sparc-sun-solaris2.8/3.3.2/include/stdio.h:194:
error: pa
rse error before '*' token
...
...
...

Anybody seen this problem? Thanks.
-Justin

On 02 Mar 2004 09:04:59 -0800, "Chris Wein" <cwein@mobilygen.com> said:
> The reason is that configure checks for cc first and then gcc. You
> almost certainly have a cc executable that basically prints out "You
> don't have the CC package". So, the test program that configure
> compiles does not work and it does not go on to try gcc. You need to
> set an environment variable CC to gcc to get this to work.
>
> C
>
>
> On Tue, 2004-03-02 at 07:19, Justin Johnson wrote:
> > Hi,
> >
> > I'm trying to build subversion 1.0.0 and its dependencies on a Solaris
> > 5.8 sparc box.
> >
> > SunOS walnut 5.8 Generic_108528-27 sun4u sparc SUNW,Ultra-Enterprise
> >
> > First I downloaded and installed the following (from
> > www.sunfreeware.com):
> >
> > autoconf
> > libtool
> > bintools
> > gcc
> >
> > They all installed into /usr/local. Then I modified my path to be
> >
> > /usr/local/bin:/usr/ccs/bin:/usr/ccs/lib:/usr/bin:/usr/ucb:/etc:.
> >
> > Then I attempt to build Berkeley DB 4.2.52 and get the following error.
> >
> > $ pwd
> > /home/svn/download/svn/db-4.2.52/build_unix
> > $ env CC=gcc ../dist/configure
> > checking build system type... sparc-sun-solaris2.8
> > checking host system type... sparc-sun-solaris2.8
> > checking if building in the top-level or dist directories... no
> > checking if --disable-cryptography option specified... no
> > checking if --disable-hash option specified... no
> > checking if --disable-queue option specified... no
> > checking if --disable-replication option specified... no
> > checking if --disable-verify option specified... no
> > checking if --enable-compat185 option specified... no
> > checking if --enable-cxx option specified... no
> > checking if --enable-debug option specified... no
> > checking if --enable-debug_rop option specified... no
> > checking if --enable-debug_wop option specified... no
> > checking if --enable-diagnostic option specified... no
> > checking if --enable-dump185 option specified... no
> > checking if --enable-java option specified... no
> > checking if --enable-mingw option specified... no
> > checking if --enable-posixmutexes option specified... no
> > checking if --enable-rpc option specified... no
> > checking if --enable-smallbuild option specified... no
> > checking if --enable-tcl option specified... no
> > checking if --enable-test option specified... no
> > checking if --enable-uimutexes option specified... no
> > checking if --enable-umrw option specified... no
> > checking if --with-mutex=MUTEX option specified... no
> > checking if --with-mutexalign=ALIGNMENT option specified... no
> > checking if --with-rpm=ARCHIVE option specified... no
> > checking if --with-tcl=DIR option specified... no
> > checking if --with-uniquename=NAME option specified... no
> > checking for ar... ar
> > checking for chmod... chmod
> > checking for cp... cp
> > checking for ln... ln
> > checking for mkdir... mkdir
> > checking for ranlib... ranlib
> > checking for ranlib... /usr/local/bin/ranlib
> > checking for rm... rm
> > checking for sh... sh
> > checking for sh... /usr/bin/sh
> > checking for strip... strip
> > checking for strip... /usr/local/bin/strip
> > checking for a BSD-compatible install... ../dist/install-sh -c
> > checking for C compiler default output... configure: error: C compiler
> > cannot create executables
> > See `config.log' for more details.
> > $
> >
> >
> > The config.log file is attached. I tried adding
> > --with-ld=/usr/local/bin/ld and --with-gnu-ld, but it continues to grab
> > /usr/css/bin/ld. Not sure how that affects things.
> >
> > Does anyone have any ideas on how to continue?
> >
> > Thanks.
> > -Justin
> > ----
> >
>
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> > For additional commands, e-mail: users-help@subversion.tigris.org
> --
> Chris Wein
> Software Engineer
> Mobilygen Corp.
> E-Mail : cwein@mobilygen.com
> Phone : 408-869-4035
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Mar 2 18:20:17 2004

This is an archived mail posted to the Subversion Users mailing list.