[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: configure fails to find Berkeley DB (subversion 1.0.0)

From: Robert Guthrie <rguthrie_at_pobox.com>
Date: 2004-03-01 16:38:37 CET

Erik Huelsmann wrote:
> There was a FAQ added very recently about exactly this problem.
>
> The FAQ includes a reference to a patch which should relieve your pain.
>
> check:
> http://subversion.tigris.org/project_faq.html#linux-bdb42-build
>
> HTH,
I think it would help except for the instructions for people not
compiling Apache at all. The entry says "If you're not building Apache,
apply the patch to the apr-util ./configure script in your Subversion
tree". The problem is, there _IS_ no apr-util/configure script included
in the subversion tar ball, which the FAQ entry (as a whole) implies.

To get it, I believe I'll have to install autoconf and run it on apr &
apr-utils individually, but being that this is the wonderful world of
not being root on AIX, I have to custom-install autoconf, and all of
this dependencies. This is a headache I'd like to avoid.

So is there supposed to be a configure script for apr-util included in
the tar-ball, or am I going to have to keep plodding along the
"try-and-compile autoconf" path?

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Mar 1 16:38:00 2004

This is an archived mail posted to the Subversion Users mailing list.