[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

database seems to be corrupt.

From: Chaffinch <mikechaffinch_at_yahoo.co.uk>
Date: 2004-03-01 11:48:44 CET

Hi,

I have just got hold of and installed Subversion 1.0. All was workin well
until the other night I came to import some new files and got an Abort Trap.
Any attempt to access the db resulted (such as svnlook) also gave an abort
trap. So I tried running db_recover. This stops the abort trap but running
this gives me the following output:

db_recover: Ignoring log file: log.0000000001: magic number 0, not 40988
db_recover: Invalid log file: log.0000000001: Invalid argument
db_recover: First log record not found
db_recover: PANIC: Invalid argument
db_recover: DB_ENV->open: DB_RUNRECOVERY: Fatal error, run database recovery

There are 3 log.000000000x files in the repos/db directory numbered 1, 6 and
7. And also one in my home numbered 1. I don't know if this is significent.

I am running db_recover with no parameters in the repos/db directory, I hope
this is correct.

Can anyone tell me what the problem is, should I be worried???

=====
Regards

Chaffinch
----------------------------------------------

        
        
                
___________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping"
your friends today! Download Messenger Now
http://uk.messenger.yahoo.com/download/index.html

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Mon Mar 1 11:47:58 2004

This is an archived mail posted to the Subversion Users mailing list.