[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: cannot find -lswigpl

From: Jason E. Stewart <jason_at_openinformatics.com>
Date: 2004-01-13 18:36:42 CET

"Gerald Richter" <richter@ecos.de> writes:

> After doing more research I found the it wasn't build by SWIG. After
> changeing to the Runtime subdirectotry of SWIG and running make && make
> install it was there, but now the troubles continued, because SWIG-1.3.20
> seems to have a lot of incompatible changes. I didn't got it to work with
> subversion 0.35.1, so I downgraded to SWIG 1.3.19 (which installed libswigpl
> without problems) and Perl bindings now works without problems :-)

There have been *huge* problems with SWIG's runtime libraries for a
long time - maintaining them has been a real pain. Dave and the other
SWIG maintainers made some efforts to fix this in 1.3.20 by not
building the runtime library unless the user specifically requested
it.

In the next major release, the runtime library will be completely
eliminated and replaced by another mechanism.

Cheers,
jas.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Tue Jan 13 18:41:28 2004

This is an archived mail posted to the Subversion Users mailing list.