[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

RE: configure fails on Solaris 2.8

From: <leif.eriksen_at_hpa.com.au>
Date: 2003-08-21 08:51:54 CEST

IIRC, the --with-berkeley-db flag helps Subversion know where the headers
are, no where you installed the libraries, though they may coincidently be
there too.

Leif Eriksen
Developer

HPA
Direct: 03 9217 5600
Fax: 03 9217 5702

www.hpa.com.au <http://www.hpa.com.au>

-----Original Message-----
From: Mikko Ruohola [mailto:polarfox@verkkotieto.com]
Sent: Thursday, August 21, 2003 4:47 PM
To: Dmitri Priimak
Cc: users@subversion.tigris.org
Subject: Re: configure fails on Solaris 2.8

well.. I've compiled svn 0.26.0 and 0.27.0 on solaris 8(or 2.8... what
ever! =) and bot work great... altought I put db sources in subversion
source tree... :)

and of cooz using gcc =)

On to, 2003-08-21 at 02:00, Dmitri Priimak wrote:
> Hi All.
>
> I was trying to build svn version 0.27.0 on Solaris and got into problem.
> Running ./configure --with-berkeley-db=/usr/local/BerkeleyDB.4.1
> I get at some point:
>
> neon configured properly
> checking for any extra libraries neon needs...
> checking for static Apache module support... no
> checking for Apache module support via DSO through APXS... found at
> /usr/local/apache2/bin/apxs
> checking httpd version... recent enough
> checking for socket in -lsocket... yes
> checking for Berkeley DB in /usr/local/BerkeleyDB.4.1 (as db4)... no
> checking for Berkeley DB in /usr/local/BerkeleyDB.4.1 (as db)... no
> configure: error: Could not find Berkeley DB 4.0.14 with names: db4 db
>
> Same works on Linux. Both machines have /usr/local/BerkeleyDB.4.1 and do
> not have anywhere file libdb4.so

**********************************************************************
IMPORTANT
The contents of this e-mail and its attachments are confidential and intended
solely for the use of the individual or entity to whom they are
addressed. If you received this e-mail in error, please notify
the HPA Postmaster, postmaster@hpa.com.au, then delete
the e-mail.

This footnote also confirms that this e-mail message has been swept for
the presence of computer viruses by MimeSweeper. Before opening or
using any attachments, check them for viruses and defects.

Our liability is limited to resupplying any affected attachments.

HPA collects personal information to provide and market our services.
For more information about use, disclosure and access see our Privacy
Policy at www.hpa.com.au
**********************************************************************

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Aug 21 08:52:52 2003

This is an archived mail posted to the Subversion Users mailing list.