[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

repository too slow suddenly

From: Wadsworth, Eric (Contractor) <wadswore_at_fhu.disa.mil>
Date: 2003-08-14 19:11:17 CEST

I restored a backup of my repository, and updated a few files here and
there, then checked out a working copy (which went file). Then I tried to
check out another working copy, and it got stuck partway through. A bunch of
CTRL-C signals finally got it to pay attention and abort the command. I
deleted the directory, and tried the checkout again. This time, it sat there
for a long time, then timed out waiting for the server.

I figured it was stuck, so on the server I ran "svnadmin recover /my/repos".
It says "Acquiring exclusive lock on repository db. Recovery is running,
please stand by...".

Well, I've been standing by for about an hour now. The whole repository is
only about 220 MB in size. I can still navigate through it via a web
browser, but each link I click on has a 10-second wait for something to
happen.

Any ideas what is going on? I'm understandably hesitant to just CTRL-C the
recover command. But I've got to get some work done, people are waiting for
this thing to be up and happy, and I don't want to give everyone the
green-light until I am sure it's happy.

--- Eric

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Thu Aug 14 19:12:20 2003

This is an archived mail posted to the Subversion Users mailing list.