[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: DESTDIR install broken

From: Joe Orton <joe_at_manyfish.co.uk>
Date: 2003-08-02 00:16:31 CEST

On Wed, Jul 30, 2003 at 06:56:09PM -0700, Ted Irons wrote:
> On a Linux system, doing a DESTDIR install with the subversion-0.25
> (and subversion-0.26) tarball, I get the error below.
>
> I tried running autogen.sh first, but that didn't help.
> Any ideas?

What version of libtool do you have, and what distribution of Linux?

Do you also have a version of subversion installed with libraries in
/usr/lib? There is a libtool bug which can cause relinking to fail
during the DESTDIR install in surprising ways if you already have
subversion libraries in /usr/lib.

I remember seeing a failure like this myself, though I can't remember
whether this was definitely due to the libtool bug.

joe

> Thanks,
> - Ted
>
>
> (cd /swl/opt/ix86-linux/tmp/subversion-0.25/subversion/mod_dav_svn;
> /bin/sh /swl/opt/ix86-linux/tmp/subversion-0.25/libtool --mode=relink
> gcc -O2 -pthread -DNEON_ZLIB -rpath /swl/opt/ix86-linux/libexec
> -avoid-version -module -o mod_dav_svn.la activity.lo deadprops.lo
> liveprops.lo log.lo merge.lo mod_dav_svn.lo repos.lo update.lo util.lo
> version.lo ../../subversion/libsvn_repos/libsvn_repos-1.la
> ../../subversion/libsvn_fs/libsvn_fs-1.la
> ../../subversion/libsvn_delta/libsvn_delta-1.la
> ../../subversion/libsvn_subr/libsvn_subr-1.la @inst_prefix_dir@)
> gcc -shared activity.lo deadprops.lo liveprops.lo log.lo merge.lo
> mod_dav_svn.lo repos.lo update.lo util.lo version.lo -Wl,--rpath
> -Wl,/swl/opt/ix86-linux/lib -L/usr/lib
> -L/swl/opt/ix86-linux/tmp/subversion-0.25/subversion/libsvn_subr/.libs
> -L/swl/opt/ix86-linux/tmp/subversion-0.25/subversion/libsvn_delta/.libs
> -L/swl/opt/ix86-linux/tmp/subversion-0.25/subversion/libsvn_fs/.libs
> -L/swl/opt/ix86-linux/lib -lsvn_repos-1 -lsvn_fs-1 -lsvn_delta-1
> -lsvn_subr-1 -pthread -Wl,-soname -Wl,mod_dav_svn.so -o
> .libs/mod_dav_svn.so
> /swl/opt/ix86-linux/bin/ld: cannot find -lsvn_repos-1
> collect2: ld returned 1 exit status
> libtool: install: error: relink `mod_dav_svn.la' with the above command
> before installing it
> libtool: install: warning: remember to run `libtool --finish
> /swl/opt/ix86-linux/libexec'
> grep:
> /swl/opt/ix86-linux/encap/subversion-0.25.tmp/swl/opt/ix86-linux/libexec/mod_dav_svn.la:
> No such file or directory
> grep:
> /swl/opt/ix86-linux/encap/subversion-0.25.tmp/swl/opt/ix86-linux/libexec/mod_dav_svn.la:
> No such file or directory
> Warning! dlname not found in
> /swl/opt/ix86-linux/encap/subversion-0.25.tmp/swl/opt/ix86-linux/libexec/mod_dav_svn.la.
> Assuming installing a .so rather than a libtool archive.
> chmod 755
> /swl/opt/ix86-linux/encap/subversion-0.25.tmp/swl/opt/ix86-linux/libexec/mod_dav_svn.so
> chmod: getting attributes of
> `/swl/opt/ix86-linux/encap/subversion-0.25.tmp/swl/opt/ix86-linux/libexec/mod_dav_svn.so':
> No such file or directory
> apxs:Error: Command failed with rc=65536
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
> For additional commands, e-mail: users-help@subversion.tigris.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Sat Aug 2 00:17:16 2003

This is an archived mail posted to the Subversion Users mailing list.