[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: MacOS X problems---Corrupt repository

From: <kfogel_at_collab.net>
Date: 2003-08-01 17:46:57 CEST

"Hamilton Link" <helink@sandia.gov> writes:
> I don't suppose there are any other ways in which the INSTALL file for
> svn is increasingly out of date? It specifically says (still) that
> 4.0.14 is the Berkeley DB version to use. Since I certainly have never
> been able to definitively say what is and isn't required to run svn,
> do people on the dev team occasionally give a quick peek at the FAQ
> and INSTALL, etc. files?

Generally, 4.0.14 is still the recommended Berkeley, but on Mac OS/X
4.1.24 or higher is required -- 4.0.14 will not work.

We'd like to recommend 4.1.x for Subversion in general, but
experiments have shown that it's slower. The problem may be more with
the way we use Berkeley than with Berkeley itself. I can't quantify
this precisely only because I don't have the threads or issues handy
right now. Some people use 4.1.x anyway; as far as I know, they don't
have correctness issues.

I'm cross-posting this to the 'users' list, where I think it would be
useful for it to be seen. If people follow up, please trim 'dev' out
of the recipients, unless there's some reason it really should go to
dev, thanks.

-Karl

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@subversion.tigris.org
For additional commands, e-mail: users-help@subversion.tigris.org
Received on Fri Aug 1 18:26:08 2003

This is an archived mail posted to the Subversion Users mailing list.