[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

multiple prompts for smart card, smart card not found, works anyway

From: D Simp <simpsonar77_at_gmail.com>
Date: Wed, 13 Jan 2016 11:26:36 -0800 (PST)

I have seen some comments elsewhere on this in the past, but have not seen any resolution...

I have a windows 7 64bit system with ActivClient Gold installed and working.

The latest version of tortoise is installed and up to date.

The SVN repo is smartcard controlled (pkcs11).

When doing anything that involves interaction with the SVN repo, tortoise prompts multiple times to enter a smart card. The error details are:

"A smart card was detected but is not the one required for the current operation. The smart card you are using may be missing required driver software or a required certificate. "

If I click cancel multiple times, the process goes ahead and then prompts for the PIN and completes the action. Sometimes, this takes over 40 prompts to complete. Normal checkouts or updates take between 4-10 clicks of the cancel button.

I know for certain that the CAC/Smart Card reader is working as I can access webpages, etc... that are smart card enabled just fine. Also, with the same card on a Linux system, I can access the same repo just fine without issues.

Is there a misconfiguration on this system? I have tried it on multiple windows 7 systems with similar results.

Thanks,
Andrew

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3155318

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2016-01-13 20:47:06 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.