[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

libapr_tsvn32.dll excluded from 1.9.3?

From: Tim Green <tim.green_at_ec-software.com>
Date: Mon, 4 Jan 2016 16:53:27 +0100

Our 32-bit application uses the client command line interface to
communicate with SVN and if Tortoise is installed that defaults to
libapr_tsvn32.dll. This DLL seems to have been excluded from Tortoise 1.9.3
in the 64-bit installation. As a result our users are getting an error
message and can only use our SVN functions if they downgrade their Tortoise
installation back to 1.9.2.

We checked the version numbers of the DLLs and they don't appear to have
changed for libapr_tsvn.dll, but a quick test with the copy of
libapr_tsvn32.dll from 1.9.2 doesn't work with 1.9.3. It just gets an
invalid address access error.

I checked all the change logs and mailing lists and couldn't find any
reference to this DLL being removed from the current installation of
Tortoise. Is it possible that this is an error, or has it been removed for
some specific reason? If so, is it possible to access the client command
line interface in a different way as of this update? Or is it necessary to
use a different client?

Regards,
Tim

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3153554

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2016-01-04 17:38:42 CET

This is an archived mail posted to the TortoiseSVN Users mailing list.