[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

1.9 fails commits on repos checked out previously on 1.8.x

From: Jamie Wardlaw <jwardlaw_at_unifire.ca>
Date: Wed, 26 Aug 2015 17:03:22 -0700 (PDT)

We have seen repeated issues with commits to repositories this week since upgrading to version 1.9

The error message is an access denied message on copying the .svn baselines. E.g.

Commit failed (details follow):
Can't move 'U:\1-Administration\Management\.svn\tmp\svn-ADD80C28' to
 'U:\1-Administration\Management\.svn\pristine\b7\b7c3f06170d83d3aac6b4489b78c4c8509c70ed6.svn-base':
 Access is denied.

No amount of updates or cleanups fix this. The repositories are on a network share.

The only way to repeatably fix this is to use the command line client to do the commit. From that point on something appears to be rectified which allows TSVN to start working again. I did notice in some cases that the \pristine copies would eventually appear so I am wondering if it is a timing issue in the new TSVN that causes it to bail early when trying to write the file.

This was never a problem in the last two years with our config.

Jamie

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3134203

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2015-08-27 09:10:26 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.