[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Windows 10 Tortoise Commit Window Hangs (and Resolution)

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Wed, 5 Aug 2015 19:25:12 +0200

On 04.08.2015 21:05, Adam Hamilton wrote:
> Just encountered this issue on multiple dev machines that had been
> updated to Windows 10 from Windows 8. I wanted to let you know the
> error and the resolution we encountered in case it helps you, or in
> case you hear this error from others.
>
> Our situation was that the commit dialog, and other dialogs that
> displayed file lists, would freeze between displaying the dialog and
> loading/populating the file list and would be unable to continue. A
> wait cursor would be displayed until we manually terminated the
> process.
>
> After looking through previous posts, it seemed that a file icon
> handler was a likely culprit. With some research, we found that
> Windows 10, even when asked not to change default programs during
> install, still changes the default image viewer to it's new Windows
> Photo Viewer program. This of course changes the icon for image
> files to this program's icon. The icon handler for this program
> seems to behave in some unexpected way (perhaps it's own fault) and
> causes tortoise to freeze whenever it attempts to display an icon for
> an image file. Therefore all dialogs that included an image in the
> file list caused an unrecoverable hang.
>
> For us, the solution was just to set a different program as the
> default program for opening image files (which is what we intended
> anyway, but the Windows 10 upgrade installer ignored this request).
> The problem was immediately resolved, although we do need to do this
> on each dev machine.
>
> I'm not sure if this should or even could be fixed within tortoise,
> or if this fix needs to come from Microsoft since their Photo Viewer
> program seems to be responsible. Even if tortoise can't fix this, I
> hope this helps other users with the same tortoise issue on Windows
> 10 to resolve it.
>
> We have already resolved this on our dev boxes, but if anyone needs
> more information from us about this I am happy to try to provide any
> answers I have or can work out.

That's very strange: I'm running Win10 here on multiple machines as
well, one with a clean install and one with an upgrade from Win8.1. I
don't see that problem on none of those machines. And I haven't changed
the default image program.

I think the problem you're seeing might be somewhere else.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest interface to (Sub)version control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3130434
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2015-08-05 19:25:05 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.