[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Incorrect behavior after changed rules

From: Stefan Küng <tortoisesvn_at_gmail.com>
Date: Wed, 8 Jul 2015 20:19:42 +0200

On 08.07.2015 17:07, Ignace Danneels wrote:
> We use subversion 1.8.1 and tortoise client 1.8.7.
> We are using the access rules in Subversion Edge to control the read/write and folder access.
>
> The issue is the following:
> Assume a user had access to a specific subfolder in a project, but the access rule changes because of whatever reason. The new access rule specifies the user no longer has access to that specific subfolder.
>
> [repo:/trunk/...../subfolder]
> &user=
>
> What I was expecting is that when I make an update of the local repository, the access rule would be enforced on the local sandbox.
>
> This would mean that the subfolder is removed from the sandbox (files modified locally remain, as well as non-versioned files).
>
> This does not happen: instead I get the following error
> Failed to mark
> <foldername>
> abscent. Already marked for updating.

You have to report this issue on the svn users list, since it's the svn
library that causes this behavior.

Stefan

-- 
        ___
   oo  // \\      "De Chelonian Mobile"
  (_,\/ \_/ \     TortoiseSVN
    \ \_/_\_/>    The coolest interface to (Sub)version control
    /_/   \_\     http://tortoisesvn.net
------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3126357
To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2015-07-08 20:19:14 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.