[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

Re: Upgrade from 1.7 to 1.87 broke stuff.

From: Ben Fritz <fritzophrenic_at_gmail.com>
Date: Wed, 4 Jun 2014 17:11:11 -0500

Go to the top-level directory in your working copy. Do the "upgrade
working copy" command from that directory. Upgrading a working copy is
an all-or-nothing thing, you can't upgrade individual files or
subdirectories.

On Wed, Jun 4, 2014 at 4:50 PM, Mike Vislocky <mike_at_netorange.com> wrote:
> When I upgraded from 1.7 to 1.87, bad things happened.
>
> Help&Manual failed to load with this error:
>
> The working copy at <path> is too old (format 29) to work with client version ;1.8.9 (r1591380)' (expects format 31). You need to upgrade the working copy first.
>
> So I clicked on "SVN Upgrade working copy" on the file's menu and was greeted with this error:
>
> Can't upgrade <path\file> as it is not a working copy root
> Working copy database 'path\file\.svn\wc.db' not found
> Additional errors:
> Cant open file 'path\file\.svn\entries': The system cannot find the path specified.
>
> Something has obviously changed between 1.7 and 1.87 that needs to be accounted for. I am not tortoise expert and have not looked at it since I installed it long ago.
>
> How might recover from the upgrade? Thanks...
>
> ------------------------------------------------------
> http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3079899
>
> To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3079900

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2014-06-05 00:11:35 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.