[svn.haxx.se] · SVN Dev · SVN Users · SVN Org · TSVN Dev · TSVN Users · Subclipse Dev · Subclipse Users · this month's index

10 seconds timeout before each operation involving network connection

From: Manuel Aebischer <Manuel.Aebischer_at_netmodule.com>
Date: Thu, 17 Apr 2014 13:30:03 +0200

We are using TortoiseSVN (latest version) on Windows7 clients together
with a VisualSVN (2.5.x) Server inside our company network. On some
clients, there was a timeout of about ten seconds before each operation
which involved contacting the server, e.g. commiting, updating,
repo-browsing, etc. We analyzed this behavior using WireShark and
SysInternals procmon. In the end, we found out that the problem exists
only on clients with network adapters showing "Unidentified Network"
such as virtual machine host adapters when no VM is running or network
adapters with wrong IP settings. When all these adapters are set to
disabled, the problem doesn't exist anymore and the transaction begins
within a second. Adapters, either physical or virtual, with unplugged
cables are no issue.
As a workaround, we tried to set the priority of the network adapter
connected to the company LAN to the highest value, but without any
success. The problem also exists with the command line client delivered
with TortoiseSVN. Can someone reproduce this behavior?

Manuel

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=3076652

To unsubscribe from this discussion, e-mail: [users-unsubscribe_at_tortoisesvn.tigris.org].
Received on 2014-04-17 14:25:35 CEST

This is an archived mail posted to the TortoiseSVN Users mailing list.